re = /(.*)\h+(\()?world(?(2)\))/m
str = 'this is my world, not my (world)
this is my world, not my world
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result