use strict;
my $str = 'this is my world, not my (world)
this is my world, not my world
';
my $regex = qr/(.*)\h+(\()?world(?(2)\))/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";