#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d(?! )\w*.\d(?! )\w*.\d(?! )\w*.\d(?! )\w*"
Local $sString = "100371 (Choice Classification) Infants/Girls Woven Short, Cotton 100371 (Single Classification) 6209.20.00.90 Infants More..." & @CRLF & _
" 100371 (Single Classification) 6204.62.90.90 Girls More..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")