import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d(?! )\\w*.\\d(?! )\\w*.\\d(?! )\\w*.\\d(?! )\\w*";
final String string = "100371 (Choice Classification) Infants/Girls Woven Short, Cotton 100371 (Single Classification) 6209.20.00.90 Infants More...\n"
+ " 100371 (Single Classification) 6204.62.90.90 Girls More...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}