re = /\d(?! )\w*.\d(?! )\w*.\d(?! )\w*.\d(?! )\w*/
str = '100371 (Choice Classification) Infants/Girls Woven Short, Cotton 100371 (Single Classification) 6209.20.00.90 Infants More...
100371 (Single Classification) 6204.62.90.90 Girls More...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end