const regex = /\d(?! )\w*.\d(?! )\w*.\d(?! )\w*.\d(?! )\w*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d(?! )\\w*.\\d(?! )\\w*.\\d(?! )\\w*.\\d(?! )\\w*', 'g')
const str = `100371 (Choice Classification) Infants/Girls Woven Short, Cotton 100371 (Single Classification) 6209.20.00.90 Infants More...
100371 (Single Classification) 6204.62.90.90 Girls More...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}