import Foundation
let pattern = #"\d(?! )\w*.\d(?! )\w*.\d(?! )\w*.\d(?! )\w*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
100371 (Choice Classification) Infants/Girls Woven Short, Cotton 100371 (Single Classification) 6209.20.00.90 Infants More...
100371 (Single Classification) 6204.62.90.90 Girls More...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)