using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.)(?![^(]*\))";
string substitution = @"\1 ";
string input = @"010000000
(10)1140006x
002200010
00000(11)01x
311200";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}