use strict;
my $str = '010000000
(10)1140006x
002200010
00000(11)01x
311200';
my $regex = qr/(.)(?![^(]*\))/mp;
my $subst = '\\1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";