#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(New )?Nintendo \d?DSi?( Lite)?( XL)?"
Local $sString = "Nintendo DS" & @CRLF & _
"Nintendo DS Lite" & @CRLF & _
"Nintendo DSi" & @CRLF & _
"Nintendo DSi XL" & @CRLF & _
"Nintendo 3DS" & @CRLF & _
"Nintendo 3DS XL" & @CRLF & _
"Nintendo 2DS" & @CRLF & _
"New Nintendo 3DS" & @CRLF & _
"New Nintendo 3DS XL" & @CRLF & _
"New Nintendo 2DS XL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")