use strict;
my $str = 'Nintendo DS
Nintendo DS Lite
Nintendo DSi
Nintendo DSi XL
Nintendo 3DS
Nintendo 3DS XL
Nintendo 2DS
New Nintendo 3DS
New Nintendo 3DS XL
New Nintendo 2DS XL';
my $regex = qr/(New )?Nintendo \d?DSi?( Lite)?( XL)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}