$re = '/(New )?Nintendo \d?DSi?( Lite)?( XL)?/m';
$str = 'Nintendo DS
Nintendo DS Lite
Nintendo DSi
Nintendo DSi XL
Nintendo 3DS
Nintendo 3DS XL
Nintendo 2DS
New Nintendo 3DS
New Nintendo 3DS XL
New Nintendo 2DS XL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);