import re
regex = re.compile(r"(New )?Nintendo \d?DSi?( Lite)?( XL)?", flags=re.MULTILINE)
test_str = ("Nintendo DS\n"
"Nintendo DS Lite\n"
"Nintendo DSi\n"
"Nintendo DSi XL\n"
"Nintendo 3DS\n"
"Nintendo 3DS XL\n"
"Nintendo 2DS\n"
"New Nintendo 3DS\n"
"New Nintendo 3DS XL\n"
"New Nintendo 2DS XL")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")