import Foundation
let pattern = #"(New )?Nintendo \d?DSi?( Lite)?( XL)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Nintendo DS
Nintendo DS Lite
Nintendo DSi
Nintendo DSi XL
Nintendo 3DS
Nintendo 3DS XL
Nintendo 2DS
New Nintendo 3DS
New Nintendo 3DS XL
New Nintendo 2DS XL
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)