using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?:\/CN|,OU)=)([^,]*)(?=(?:,[^,]*)*,DC)";
string input = @"LDAP://abc.123.net/CN=SERVER123ABC,CN=Servers,OU=Test OU,OU=Test OU 2,DC=abc,DC=123,DC=net";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}