const regex = /(?<=(?:\/CN|,OU)=)([^,]*)(?=(?:,[^,]*)*,DC)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(?:\\\/CN|,OU)=)([^,]*)(?=(?:,[^,]*)*,DC)', 'gm')
const str = `LDAP://abc.123.net/CN=SERVER123ABC,CN=Servers,OU=Test OU,OU=Test OU 2,DC=abc,DC=123,DC=net`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}