re = /(?<=(?:\/CN|,OU)=)([^,]*)(?=(?:,[^,]*)*,DC)/m
str = 'LDAP://abc.123.net/CN=SERVER123ABC,CN=Servers,OU=Test OU,OU=Test OU 2,DC=abc,DC=123,DC=net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end