$re = '/(?<=(?:\/CN|,OU)=)([^,]*)(?=(?:,[^,]*)*,DC)/m';
$str = 'LDAP://abc.123.net/CN=SERVER123ABC,CN=Servers,OU=Test OU,OU=Test OU 2,DC=abc,DC=123,DC=net';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);