package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(\w+))?\s?\b(\d+)\s?x\s?(\d+)\s?(cm)\b`)
var str = `
30 x 30 cm
30x30cm
30x30 cm
Ixxx 30x30cm
xxxx (30x30cm)
xxxx (30 x 30 cm)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}