import re
regex = re.compile(r"(?:(\w+))?\s?\b(\d+)\s?x\s?(\d+)\s?(cm)\b")
test_str = ("\n"
"30 x 30 cm\n"
"30x30cm\n"
"30x30 cm\n"
"Ixxx 30x30cm\n"
"xxxx (30x30cm)\n"
"xxxx (30 x 30 cm)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")