const regex = /(?:(\w+))?\s?\b(\d+)\s?x\s?(\d+)\s?(cm)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(\\w+))?\\s?\\b(\\d+)\\s?x\\s?(\\d+)\\s?(cm)\\b', 'g')
const str = `
30 x 30 cm
30x30cm
30x30 cm
Ixxx 30x30cm
xxxx (30x30cm)
xxxx (30 x 30 cm)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}