package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<c>[A-Z])`)
var str = `MyPropertyName`
var substitution = "\L_\0"
fmt.Println(re.ReplaceAllString(str, substitution))
}