$re = '/(?<c>[A-Z])/m';
$str = 'MyPropertyName';
$subst = "\L_\0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;