import Foundation
let pattern = #"(?<c>[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"MyPropertyName"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\L_\0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)