use strict;
my $str = 'MyPropertyName';
my $regex = qr/(?<c>[A-Z])/mp;
my $subst = '\\L_\\0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";