const regex = /(?<c>[A-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<c>[A-Z])', 'gm')
const str = `MyPropertyName`;
const subst = `\L_\0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);