package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)p([1]?[0-9]|20)\.b([1]?[0-9]|20)\.val`)
var str = `p20.b18.val
p3.b4.val
p.b.val
p3.b1.val`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}