// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)p([1]?[0-9]|20)\.b([1]?[0-9]|20)\.val").unwrap();
let string = "p20.b18.val
p3.b4.val
p.b.val
p3.b1.val";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}