re = /p([1]?[0-9]|20)\.b([1]?[0-9]|20)\.val/m
str = 'p20.b18.val
p3.b4.val
p.b.val
p3.b1.val'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end