$re = '/p([1]?[0-9]|20)\.b([1]?[0-9]|20)\.val/m';
$str = 'p20.b18.val
p3.b4.val
p.b.val
p3.b1.val';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);