const regex = /p([1]?[0-9]|20)\.b([1]?[0-9]|20)\.val/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('p([1]?[0-9]|20)\\.b([1]?[0-9]|20)\\.val', 'gm')
const str = `p20.b18.val
p3.b4.val
p.b.val
p3.b1.val`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}