import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{\\s*lang\\(\\\"(.*?)\\\"(.*?)\\}\\}";
final String string = "<div class=\"col-12 col-md-8 offset-md-2 mb-2\">\n"
+ " <h5 class=\"text-danger\">\n"
+ " {{lang(\"SiteCadastro.alterarsenha.erromsg1\")|raw}}\n"
+ " <br><br>\n"
+ " {{lang(\"SiteCadastro.alterarsenha.erromsg2\")|raw}}\n"
+ " </h5>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}