# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"{{\s*lang\(\"(.*?)\"(.*?)}}"
test_str = ("<div class=\"col-12 col-md-8 offset-md-2 mb-2\">\n"
" <h5 class=\"text-danger\">\n"
" {{lang(\"SiteCadastro.alterarsenha.erromsg1\")|raw}}\n"
" <br><br>\n"
" {{lang(\"SiteCadastro.alterarsenha.erromsg2\")|raw}}\n"
" </h5>\n"
" </div>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.