use strict;
my $str = '<div class="col-12 col-md-8 offset-md-2 mb-2">
<h5 class="text-danger">
{{lang("SiteCadastro.alterarsenha.erromsg1")|raw}}
<br><br>
{{lang("SiteCadastro.alterarsenha.erromsg2")|raw}}
</h5>
</div>';
my $regex = qr/{{\s*lang\(\"(.*?)\"(.*?)}}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}