import Foundation
let pattern = #"{{\s*lang\(\"(.*?)\"(.*?)}}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div class="col-12 col-md-8 offset-md-2 mb-2">
                <h5 class="text-danger">
                    {{lang("SiteCadastro.alterarsenha.erromsg1")|raw}}
                    <br><br>
                    {{lang("SiteCadastro.alterarsenha.erromsg2")|raw}}
                </h5>
            </div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)