# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\(([^)]*)\))(\s?)(([0-9]{0,5})(\-)?([0-9]{0,4}))$/$2 $4/g;t' <<< "(13)300-413"