const regex = /(\(([^)]*)\))(\s?)(([0-9]{0,5})(\-)?([0-9]{0,4}))$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\(([^)]*)\\))(\\s?)(([0-9]{0,5})(\\-)?([0-9]{0,4}))$', 'g')
const str = `(13)300-413`;
const subst = `$2 $4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);