package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\(([^)]*)\))(\s?)(([0-9]{0,5})(\-)?([0-9]{0,4}))$`)
var str = `(13)300-413`
var substitution = "$2 $4"
fmt.Println(re.ReplaceAllString(str, substitution))
}