import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\(([^)]*)\\))(\\s?)(([0-9]{0,5})(\\-)?([0-9]{0,4}))$";
final String string = "(13)300-413";
final String subst = "$2 $4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}