#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\[ERR]\h*(?:\R.*){2}"
Local $sString = "2023-03-15 18:14:31.149 -04:00 [ERR]" & @CRLF & _
" Exception Time: 3/15/2023 6:14:31 PM" & @CRLF & _
" Exception Message: Could not find file '\\XXXXX01\Files\51372\Working\.xml'."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")