$re = '/.*\[ERR]\h*(?:\R.*){2}/m';
$str = '2023-03-15 18:14:31.149 -04:00 [ERR]
Exception Time: 3/15/2023 6:14:31 PM
Exception Message: Could not find file \'\\\\XXXXX01\\Files\\51372\\Working\\.xml\'.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);