import re
regex = re.compile(r".*\[ERR]\h*(?:\R.*){2}", flags=re.MULTILINE)
test_str = ("2023-03-15 18:14:31.149 -04:00 [ERR]\n"
" Exception Time: 3/15/2023 6:14:31 PM\n"
" Exception Message: Could not find file '\\\\XXXXX01\\Files\\51372\\Working\\.xml'.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")