import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\[ERR]\\h*(?:\\R.*){2}";
final String string = "2023-03-15 18:14:31.149 -04:00 [ERR]\n"
+ " Exception Time: 3/15/2023 6:14:31 PM\n"
+ " Exception Message: Could not find file '\\\\XXXXX01\\Files\\51372\\Working\\.xml'.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}