using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"gift.*?(\d+(?:,\d+)*(?:\.\d+)?)";
string input = @"I bought a beautiful gift for my friend. It cost me US$ 999. My friend was very happy. But then she asked for a US$1,700 gift";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}