import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "gift.*?(\\d+(?:,\\d+)*(?:\\.\\d+)?)";
final String string = "I bought a beautiful gift for my friend. It cost me US$ 999. My friend was very happy. But then she asked for a US$1,700 gift";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}