const regex = /gift.*?(\d+(?:,\d+)*(?:\.\d+)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('gift.*?(\\d+(?:,\\d+)*(?:\\.\\d+)?)', 'gm')
const str = `I bought a beautiful gift for my friend. It cost me US\$ 999. My friend was very happy. But then she asked for a US\$1,700 gift`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}