package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)gift.*?(\d+(?:,\d+)*(?:\.\d+)?)`)
var str = `I bought a beautiful gift for my friend. It cost me US$ 999. My friend was very happy. But then she asked for a US$1,700 gift`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}