re = /gift.*?(\d+(?:,\d+)*(?:\.\d+)?)/m
str = 'I bought a beautiful gift for my friend. It cost me US$ 999. My friend was very happy. But then she asked for a US$1,700 gift'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end