#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)https?://(?:www.)?mysite\.(?:nl|com)(.*)"
Local $sString = "http://www.mysite.com/lmds?vanall=true" & @CRLF & _
"https://mysite.com" & @CRLF & _
"https://mysite.com/pricing" & @CRLF & _
"https://www.mysite.com/lmds" & @CRLF & _
"https://mysite.com/lmds" & @CRLF & _
"http://www.mysite.nl/lmds" & @CRLF & _
"http://mysite.nl/lmds" & @CRLF & _
"http://test.mysite.com/lmds" & @CRLF & _
"http://mysite.nl/lmds" & @CRLF & _
"http://www.mysite.nl"
Local $sSubst = "https://www.commoneasy.nl${1}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)