$re = '`https?://(?:www.)?mysite\.(?:nl|com)(.*)`m';
$str = 'http://www.mysite.com/lmds?vanall=true
https://mysite.com
https://mysite.com/pricing
https://www.mysite.com/lmds
https://mysite.com/lmds
http://www.mysite.nl/lmds
http://mysite.nl/lmds
http://test.mysite.com/lmds
http://mysite.nl/lmds
http://www.mysite.nl';
$subst = "https://www.commoneasy.nl${1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;